Downloads : 5,161
Downloaded 454,760 times.
AND COUNTING

Translation

Account

All our aircraft are compatible with the new P3D v5.

Although our installers don't have the default P3D v5 installation path, you can manually install them selecting the P3D v4.4 (or up) and then choosing the P3D v5 root folder.

If your aircraft utilizes Navigraph (Proline21 and some of our G1000) and/or a weather radar you need our "Carenado P3Dv5 Patch". This is a generic patch which requires to be run only once (no matter how many Carenado aircraft do you have).

You can get more information and the patch clicking in the link below.

Source
Installing Carenado aircraft in P3Dv5